Documentation of the module zlib: Introduction

Introduction

[<<<] [>>>]


Documentation of the module zlib: Zlib functions

Zlib functions

To use these function the program has to import the file zlib.bas

import zlib.bas
--------------------------------------

The functions in this module are:


Documentation of the module zlib: Compress a string

Compress a string

CompressedString = zlib::Compress(UncompressedString)
This function implements a simple compression interface.


Documentation of the module zlib: Uncompress a string

Uncompress a string

UncompressedString = zlib::UnCompress(CompressedString)
This function implements a simple uncompression interface.


Documentation of the module zlib: Compress a file

Compress a file

zlib::gzip input_file [,output_file]
This command compresses a file.


Documentation of the module zlib: Uncompress a file

Uncompress a file

zlib::gunzip input_file [,output_file]
This command uncompresses a file.


Documentation of the module zlib

by Peter Verhas